summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2016-10-14 07:12:33 +0100
committerDave Airlie <airlied@redhat.com>2016-10-19 10:15:43 +1000
commit3f7ef2488938d31b5ead043891fadc3cee4c6f05 (patch)
treee8ca48ce50b09485f1d0df789192394749dfd3e7 /src/Makefile.am
parentec0bc14a700c2503d834ac0763f4cfbe312998fa (diff)
anv: move to using shared wsi code
This moves the shared code to a common subdirectory and makes anv linked to that code instead of the copy it was using. Reviewed-by: Jason Ekstrand <jason@jlekstrand.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b63d135fcc7..1347120f186 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -115,6 +115,10 @@ if HAVE_INTEL_DRIVERS
SUBDIRS += intel/tools
endif
+if HAVE_VULKAN_COMMON
+SUBDIRS += vulkan/wsi
+endif
+
## Requires the i965 compiler (part of mesa) and wayland-drm
if HAVE_INTEL_VULKAN
SUBDIRS += intel/vulkan