summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorNeha Bhende <bhenden@vmware.com>2020-11-26 08:47:10 -0800
committerMarge Bot <eric+marge@anholt.net>2020-12-03 12:39:02 +0000
commit12fa2d2ac22ef3ddbc8c5efaf55064fe1a19fd29 (patch)
tree975661e955d2e15b00393d2396beb9a6a6bbd9f7 /meson_options.txt
parent81702c0ba6bc588d50c11aeb5975eca57bc18848 (diff)
meson.build: Use SSE math for MinGW X86 build as per sse2 option
This patch adds missing compiler flags to build 32bit driver. It helps to build 32bit using mingw successfully Generated GL driver is tested using piglit, glretrace, conform and some opengl apps Reviewed-by: Brian Paul <brianp@vmware.com> Reviewed-by: Charmaine Lee <charmainel@vmware.com> Reviewed-by: Jose Fonseca <jfonseca@vmware.com> Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7806>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 8bc3a228f25..949d7d39774 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -441,3 +441,9 @@ option(
value : 'auto',
description : 'Use ZSTD instead of ZLIB in some cases.'
)
+option(
+ 'sse2',
+ type : 'boolean',
+ value : true,
+ description : 'use msse2 flag for mingw x86. Default: true',
+)