summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2018-06-06 20:25:09 -0700
committerMatt Turner <mattst88@gmail.com>2018-06-07 14:16:44 -0700
commita5abb2da74d3a892427499961aaef194d9ce1edf (patch)
tree3d14d0f1f8195c410d69c8ba1ad83e934f1b7795 /meson_options.txt
parent8f2421d73be596c12019196189255f22fd3edb54 (diff)
meson: Add support for read-only text segment on x86
Port of 6dfc5e28f7d0 (configure.ac: Add support to enable read-only text segment on x86.) to Meson. Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 2c1f514debe..28e92509198 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -225,6 +225,12 @@ option(
description : 'Build assembly code if possible'
)
option(
+ 'glx-read-only-text',
+ type : 'boolean',
+ value : false,
+ description : 'Disable writable .text section on x86 (decreases performance)'
+)
+option(
'llvm',
type : 'combo',
value : 'auto',