summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpal1000 <liviuprodea@yahoo.com>2022-07-21 13:02:07 +0300
committerMarge Bot <emma+marge@anholt.net>2022-09-02 03:24:20 +0000
commitf23dbcd6420188ba447e3fc50cf316dc20fb4114 (patch)
treef80ce14db312aa23dbcbe1690d011e614adee13f /meson.build
parentc59e913e9149c2a105f862c9e7bc69677ba09e47 (diff)
meson: Only draw with llvm depends on native directly
Tests, softpipe or AMD drivers don't depend on it directly Fixes: 3955dd07 ("meson/gallium: Add an option to not use LLVM for gallium draw module") Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/6817 Reviewed-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Tested-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Reviewed-by: Jesse Natalie <jenatali@microsoft.com> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17675>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index f763f8d00ae..bec326c462f 100644
--- a/meson.build
+++ b/meson.build
@@ -1703,7 +1703,7 @@ endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit', 'core', 'executionengine', 'scalaropts', 'transformutils', 'instcombine']
llvm_optional_modules = ['coroutines']
if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
- llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']
+ llvm_modules += ['amdgpu', 'bitreader', 'ipo']
if with_gallium_r600
llvm_modules += 'asmparser'
endif
@@ -1719,7 +1719,8 @@ if with_clc
llvm_modules += ['coverage', 'target', 'linker', 'irreader', 'option', 'libdriver', 'lto']
llvm_optional_modules += ['all-targets']
endif
-if with_tests or with_gallium_softpipe
+draw_with_llvm = get_option('draw-use-llvm')
+if draw_with_llvm
llvm_modules += 'native'
endif
@@ -1765,7 +1766,6 @@ endif
dep_llvm = null_dep
with_llvm = false
-draw_with_llvm = get_option('draw-use-llvm')
if _llvm != 'disabled'
dep_llvm = dependency(
'llvm',