summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKai Wasserbäch <kai@dev.carbon-project.org>2022-04-19 20:41:29 +0200
committerMarge Bot <emma+marge@anholt.net>2022-08-23 19:23:05 +0000
commit559c027adeaa33d19c8cfee828cc7220239fea70 (patch)
tree493f18bda5a369ac3af960eab84c68971840f26d /meson.build
parent98ba1e0d817e0354aad5d82eb9a2dc4cce33540f (diff)
chore(deps): clover: raise the minimum LLVM version to 11.0.0
LLVM 11 was released in October 2020. If you want to build against Mesa's Git version, that seems like enough time to upgrade to at least LLVM 11 (Debian stable has this too). It reduces the amount of #if gates we need and more will be incoming again, given the Opaque Pointer transition. Additionally radeonsi is already requiring LLVM 11. Therefore the minimum will have been LLVM 11 for many builds anyway. Note that clc is kept to LLVM 10 for the time being. Signed-off-by: Kai Wasserbäch <kai@dev.carbon-project.org> Reviewed-by: Karol Herbst <kherbst@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/16047>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index e0c4f18afe4..492142f0570 100644
--- a/meson.build
+++ b/meson.build
@@ -1723,12 +1723,10 @@ if with_tests or with_gallium_softpipe
llvm_modules += 'native'
endif
-if with_amd_vk or with_gallium_radeonsi
+if with_amd_vk or with_gallium_radeonsi or with_gallium_opencl
_llvm_version = '>= 11.0.0'
elif with_clc
_llvm_version = '>= 10.0.0'
-elif with_gallium_opencl
- _llvm_version = '>= 8.0.0'
else
_llvm_version = '>= 3.9.0'
endif