summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYonggang Luo <luoyonggang@gmail.com>2022-07-28 13:54:55 +0800
committerMarge Bot <emma+marge@anholt.net>2022-07-29 12:57:26 +0000
commit34572042c792fe1cb58e233f9c5a6e8ed93a9d7b (patch)
tree9f40406b04268b460b147f77f0d474f8298a0769 /meson.build
parent155c8bc9646bd70925982a10a8f526c33f71a869 (diff)
gallium: Move -DHAVE_PIPE_LOADER_DRI and -DHAVE_PIPE_LOADER_KMS to be pre_args
There is non pipe-loader source code depends on it. After doing this, we found that shared library pipe_swrast depends on libswdri The error message is: src/gallium/targets/pipe-loader/pipe_swrast.so.p/pipe_swrast.c.o:pipe_swrast.c:swrast_driver_descriptor: error: undefined reference to 'dri_create_sw_winsys' src/gallium/targets/pipe-loader/pipe_swrast.so.p/pipe_swrast.c.o:pipe_swrast.c:swrast_driver_descriptor: error: undefined reference to 'kms_dri_create_winsys' Signed-off-by: Yonggang Luo <luoyonggang@gmail.com> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17784>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a3724a16551..ae596676b84 100644
--- a/meson.build
+++ b/meson.build
@@ -1689,6 +1689,13 @@ if dep_libdrm.found()
endif
endif
+if with_dri
+ pre_args += '-DHAVE_PIPE_LOADER_DRI'
+endif
+if with_gallium_drisw_kms
+ pre_args += '-DHAVE_PIPE_LOADER_KMS'
+endif
+
dep_libudev = dependency('libudev', required : false)
if dep_libudev.found()
pre_args += '-DHAVE_LIBUDEV'