summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2021-04-09 09:51:38 -0700
committerMarge Bot <emma+marge@anholt.net>2021-12-03 23:53:06 +0000
commitf464871932882003e01e3459c8d126dd975d60f8 (patch)
treec5dd45f925deba677de2f745c8f30502dbe8bf36 /meson.build
parent184a690fca700aa9ef2ae2e58b0f4bd86562aa6d (diff)
classic/nouveau: Remove driver
This will now only be available in the Amber branch Reviewed-by: Emma Anholt <emma@anholt.net> Acked-by: Jason Ekstrand <jason@jlekstrand.net> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10153>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 03e7aeedec7..0019331b7e6 100644
--- a/meson.build
+++ b/meson.build
@@ -178,11 +178,9 @@ if dri_drivers.contains('auto')
if system_has_kms_drm
# TODO: PPC, Sparc
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
- dri_drivers = ['i915', 'i965', 'nouveau']
- elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
+ dri_drivers = ['i915', 'i965']
+ elif ['arm', 'aarch64', 'mips', 'mips64'].contains(host_machine.cpu_family())
dri_drivers = []
- elif ['mips', 'mips64', 'riscv32', 'riscv64'].contains(host_machine.cpu_family())
- dri_drivers = ['nouveau']
else
error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
host_machine.cpu_family()))
@@ -198,7 +196,6 @@ endif
with_dri_i915 = dri_drivers.contains('i915')
with_dri_i965 = dri_drivers.contains('i965')
-with_dri_nouveau = dri_drivers.contains('nouveau')
with_dri = dri_drivers.length() != 0
@@ -1597,7 +1594,7 @@ _libdrm_checks = [
['intel', with_dri_i915 or with_gallium_i915],
['amdgpu', (with_amd_vk and not with_platform_windows) or with_gallium_radeonsi],
['radeon', (with_gallium_radeonsi or with_gallium_r300 or with_gallium_r600)],
- ['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
+ ['nouveau', with_gallium_nouveau],
]
# Loop over the enables versions and get the highest libdrm requirement for all