summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2022-03-30 10:24:25 -0400
committerAdam Jackson <ajax@redhat.com>2022-03-31 09:58:49 -0400
commitd43e6a9a497f1d56d194572a1e5ab87cafa34d5e (patch)
tree4df732dbdba8569ae10d317c19dd370d0aa8a246 /meson.build
parent97554218f403e6515b560d9782a14df09d7339c8 (diff)
dri: Remove the megadriver compat stub
This is for compatibility with loaders that don't know about __DRI_DRIVER_GET_EXTENSIONS. xserver has supported that since 1.15.0, which is almost nine years old now. While we're about it, fix a comment in meson.build that used to be about megadrivers to reflect reality. Reviewed-by: Emma Anholt <emma@anholt.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15649>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 765cc4b9ad3..c9cded59d51 100644
--- a/meson.build
+++ b/meson.build
@@ -1491,7 +1491,7 @@ if not cc.has_function('dlopen')
dep_dl = cc.find_library('dl', required : host_machine.system() != 'windows')
endif
if cc.has_function('dladdr', dependencies : dep_dl)
- # This is really only required for megadrivers
+ # This is really only required for util/disk_cache.h
pre_args += '-DHAVE_DLADDR'
endif