summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2021-02-19 10:34:49 -0600
committerMarge Bot <emma+marge@anholt.net>2022-03-21 11:26:44 +0000
commitc15bf88f011d204c11e893c5ff0fd018a0262a39 (patch)
tree8b350c2046b5f9f251511ea3d1f6f8b260fbdf97 /meson.build
parentb1e7ce84cc6ee4612313734bc4e8055a959ea078 (diff)
intel: Add a little OpenCL C compiler binary
v2: Fix up indentation (Marcin) s/gen/gfx/ (Marcin) Deal with fd closing in success/fail cases (Marin) Reviewed-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13171>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1b10d85712e..24165943a14 100644
--- a/meson.build
+++ b/meson.build
@@ -288,7 +288,8 @@ if with_aco_tests and not with_amd_vk
endif
with_microsoft_clc = get_option('microsoft-clc').enabled()
-with_clc = with_microsoft_clc
+with_intel_clc = get_option('intel-clc').enabled()
+with_clc = with_microsoft_clc or with_intel_clc
with_libclc = with_clc
with_spirv_to_dxil = get_option('spirv-to-dxil')