summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLeandro Ribeiro <leandro.ribeiro@collabora.com>2021-11-15 13:50:50 -0300
committerMarge Bot <emma+marge@anholt.net>2021-11-26 16:06:09 +0000
commita25d4dd27615ff1ff2390402de57213ca35600a1 (patch)
tree010eb6589b1c27116d2b6c6339b02e68c9dba07c /meson.build
parentcd39180cfab20734744b379b085cc3b5c2cecd3a (diff)
loader: add function to get render node from dev_t
Add function loader_get_render_node() to help us to get a render node from dev_t. If the device does not expose a render node, this new function returns NULL. As this function uses drmGetDeviceFromDevId(), we bump libdrm minimal version to 2.4.109. Signed-off-by: Leandro Ribeiro <leandro.ribeiro@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/11248>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 1 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index 9b4e5e28864..d249418ea60 100644
--- a/meson.build
+++ b/meson.build
@@ -1584,7 +1584,7 @@ _drm_amdgpu_ver = '2.4.107'
_drm_radeon_ver = '2.4.71'
_drm_nouveau_ver = '2.4.102'
_drm_intel_ver = '2.4.75'
-_drm_ver = '2.4.81'
+_drm_ver = '2.4.109'
_libdrm_checks = [
['intel', with_dri_i915 or with_gallium_i915],
@@ -1594,17 +1594,6 @@ _libdrm_checks = [
['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
]
-# VC4 only needs core libdrm support of this version, not a libdrm_vc4
-# library.
-if with_gallium_vc4
- _drm_ver = '2.4.89'
-endif
-
-# etnaviv only needs core libdrm
-if with_gallium_etnaviv
- _drm_ver = '2.4.89'
-endif
-
# Loop over the enables versions and get the highest libdrm requirement for all
# active drivers.
_drm_blame = ''