summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas H.P. Andersen <phomes@gmail.com>2022-01-19 00:59:39 +0100
committerMarge Bot <emma+marge@anholt.net>2022-01-19 04:55:55 +0000
commit9e839620daa0d157230acfa2fe84cd9dc248031e (patch)
tree71a6791c70ad13bee1607587eca010efc4b5e015 /meson.build
parent71673cd2d4da7c8284defb76c03a8865a4c5c5a4 (diff)
meson: add check kwarg to run_command
run_command will change the default for the check arg to true in the future. If it is true then meson will exit if the command fails. It must be false here as we check the return code to provide a meaningful error message. With meson 0.61 we get the following warning: WARNING: You should add the boolean check kwarg to the run_command call. It currently defaults to false, but it will default to true in future releases of meson. See also: https://github.com/mesonbuild/meson/issues/9300 Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14602>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 08f39306a29..50d067984ca 100644
--- a/meson.build
+++ b/meson.build
@@ -996,7 +996,7 @@ has_mako = run_command(
from distutils.version import StrictVersion
import mako
assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
- ''')
+ ''', check: false)
if has_mako.returncode() != 0
error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
endif