summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2021-11-05 09:52:05 +1000
committerMarge Bot <emma+marge@anholt.net>2021-11-09 04:33:06 +0000
commit995f38838fc7aa485714c7574be6143c5badee5c (patch)
tree5820b7a3d0fe476a7ee2c63c956be2dfba10d03e /meson.build
parent40157bc2b0b534ce78fa129fdb978ab0486d87f1 (diff)
meson: allow building with vulkan beta extensions enabled.
This is just a precursor to anyone enabling beta stuff later. Reviewed-by: Emma Anholt <emma@anholt.net> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13685>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3aa9a6b4f9f..e1f5fb30db8 100644
--- a/meson.build
+++ b/meson.build
@@ -333,6 +333,11 @@ else
with_dri_platform = 'none'
endif
+with_vulkan_beta = get_option('vulkan-beta')
+if with_vulkan_beta
+ pre_args += '-DVK_ENABLE_BETA_EXTENSIONS'
+endif
+
_platforms = get_option('platforms')
if _platforms.contains('auto')
if system_has_kms_drm