summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFrank Binns <frank.binns@imgtec.com>2022-02-25 10:28:39 +0000
committerFrank Binns <frank.binns@imgtec.com>2022-03-22 15:04:55 +0000
commit8991e646411b73c1e03278267c80758e921f2352 (patch)
treec473fa0666deaabd186f7665124f39366560e9f9 /meson.build
parent5d151ddfba2b434825c48d2eff222b15911fcb82 (diff)
pvr: Add a Vulkan driver for Imagination Technologies PowerVR Rogue GPUs
Co-authored-by: Rajnesh Kanwal <rajnesh.kanwal@imgtec.com> Co-authored-by: Karmjit Mahil <Karmjit.Mahil@imgtec.com> Co-authored-by: Simon Perretta <simon.perretta@imgtec.com> Co-authored-by: Alexander Wasey <Alexander.Wasey@imgtec.com> Signed-off-by: Frank Binns <frank.binns@imgtec.com> Signed-off-by: Rajnesh Kanwal <rajnesh.kanwal@imgtec.com> Signed-off-by: Karmjit Mahil <Karmjit.Mahil@imgtec.com> Signed-off-by: Simon Perretta <simon.perretta@imgtec.com> Signed-off-by: Alexander Wasey <Alexander.Wasey@imgtec.com> Acked-by: Jason Ekstrand <jason.ekstrand@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15243>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 24165943a14..764381cdc0b 100644
--- a/meson.build
+++ b/meson.build
@@ -272,6 +272,8 @@ with_swrast_vk = _vulkan_drivers.contains('swrast')
with_virtio_vk = _vulkan_drivers.contains('virtio-experimental')
with_freedreno_kgsl = get_option('freedreno-kgsl')
with_broadcom_vk = _vulkan_drivers.contains('broadcom')
+with_imagination_vk = _vulkan_drivers.contains('imagination-experimental')
+with_imagination_srv = get_option('imagination-srv')
with_any_vk = _vulkan_drivers.length() != 0
with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk