summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas H.P. Andersen <phomes@gmail.com>2021-12-16 22:28:42 +0100
committerMarge Bot <emma+marge@anholt.net>2021-12-18 10:34:44 +0000
commit88d0aeab6da3cc720314db99110cd10bf5d46232 (patch)
treed59e160e880803bbf35be74a04ba9023926245a6 /meson.build
parenteebb2dedb27652761f9c59c4a489ba46c583ab4e (diff)
meson: drop compatability with < 0.48
Before meson 0.48 the cpu_family() would return 'ppc64le' on little endian power8. In newer versions it returns 'ppc64' and endianness should be checked with endian() We now require meson >= 0.53 so we can drop the compatability with older versions. The old behavior was added in e430a034b9d2be626557931cd29808a3161889f1 Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14240>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 2 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 03dda9ee3e7..597ea7057f9 100644
--- a/meson.build
+++ b/meson.build
@@ -880,12 +880,7 @@ elif _power8 == 'false'
warning('power8 option "false" deprecated, please use "disabled" instead.')
endif
if _power8 != 'disabled'
- # on old versions of meson the cpu family would return as ppc64le on little
- # endian power8, this was changed in 0.48 such that the family would always
- # be ppc64 regardless of endianness, and then the machine.endian() value
- # should be checked. Since we support versions < 0.48 we need to use
- # startswith.
- if host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
+ if host_machine.cpu_family() == 'ppc64' and host_machine.endian() == 'little'
if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.8')
error('Altivec is not supported with gcc version < 4.8.')
endif
@@ -1338,7 +1333,7 @@ elif host_machine.cpu_family() == 'sparc64'
with_asm_arch = 'sparc'
pre_args += ['-DUSE_SPARC_ASM']
endif
-elif host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
+elif host_machine.cpu_family() == 'ppc64' and host_machine.endian() == 'little'
if system_has_kms_drm
with_asm_arch = 'ppc64le'
pre_args += ['-DUSE_PPC64LE_ASM']