summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas H.P. Andersen <phomes@gmail.com>2021-12-16 23:09:55 +0100
committerMarge Bot <emma+marge@anholt.net>2021-12-18 10:34:44 +0000
commit84b21fea46d2b5670b3114cd48a7e859b2e42a35 (patch)
tree05124e5afe6b113e9318eb99fae4c9208fc82ed8 /meson.build
parent44dba714f558ba9d56cff9297086c0be81db522f (diff)
meson: drop a temp formatting variable
This was only needed in meson < 0.50 Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14240>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 0a93ca724ed..f23af107966 100644
--- a/meson.build
+++ b/meson.build
@@ -2158,18 +2158,12 @@ subdir('include')
subdir('bin')
subdir('src')
-# Meson 0.49 and earlier seems to have a bug that fails to evaluate the string-
-# formatting below unless the first argument is passed as a variable. This has
-# been fixed in Meson 0.50 and beyond, but we need to keep it like this for now
-# for backwards compatibility.
-_with_opengl_string = with_opengl ? 'yes' : 'no'
-
lines = ['',
'prefix: ' + get_option('prefix'),
'libdir: ' + get_option('libdir'),
'includedir: ' + get_option('includedir'),
'',
- 'OpenGL: @0@ (ES1: @1@ ES2: @2@)'.format(_with_opengl_string,
+ 'OpenGL: @0@ (ES1: @1@ ES2: @2@)'.format(with_opengl ? 'yes' : 'no',
with_gles1 ? 'yes' : 'no',
with_gles2 ? 'yes' : 'no'),
]