summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLeandro Ribeiro <leandro.ribeiro@collabora.com>2021-11-15 13:51:12 -0300
committerMarge Bot <emma+marge@anholt.net>2021-11-26 16:06:09 +0000
commit83916ae0b9b920c521bf9bb3e5f82fb911b3a3cf (patch)
tree2bec0e16eaf9ee61857248363a2294f740d578b4 /meson.build
parenta25d4dd27615ff1ff2390402de57213ca35600a1 (diff)
egl/wayland: add initial dma-buf feedback support
This bumps the supported dma-buf version up to 4 and adds the initial dma-buf feedback implementation. It follows the changes in the dma-buf protocol extension [1] to include the dma-buf feedback interface, which should be incorporated by most Wayland compositors in the future. From version 4 onwards, the dma-buf modifier events are not sent by the compositor anymore, so we use the default feedback to pick the set of formats/modifiers supported by the compositor. Also, we try to avoid the wl_drm device event and instead use the dma-buf feedback main device. We only fallback to wl_drm when the compositor advertises a device that does not have a render node associated. In this initial dma-buf feedback implementation we still don't do anything with the per-surface dma-buf feedback, but in the next commits we add proper support. It's important to mention that this also bumps the minimal supported version of wayland-protocols to 1.24, in order to include [1]. [1] https://gitlab.freedesktop.org/wayland/wayland-protocols/-/merge_requests/8 This patch is based on previous work of Scott Anderson (@ascent). Signed-off-by: Scott Anderson <scott.anderson@collabora.com> Signed-off-by: Leandro Ribeiro <leandro.ribeiro@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/11248>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d249418ea60..f5f0f7125bc 100644
--- a/meson.build
+++ b/meson.build
@@ -1990,7 +1990,7 @@ if with_platform_wayland
else
wl_scanner_arg = 'code'
endif
- dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
+ dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.24')
dep_wayland_client = dependency('wayland-client', version : '>=1.18')
dep_wayland_server = dependency('wayland-server', version : '>=1.18')
if with_egl