summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2021-04-15 10:07:40 -0700
committerMarge Bot <emma+marge@anholt.net>2021-12-03 23:53:06 +0000
commit76791db0882b3715cd7d0a47fd14e1f784901b09 (patch)
treeaad58572b8fb056becbe2dff81e46b552f6f215c /meson.build
parent901e0d6a11b647069ebd1b381bd0c25741d072b3 (diff)
mesa/x11: Remove the swrast-classic-based fake libGL
If you want this you will almost certainly be happier with the gallium version, giving you llvmpipe instead of swrast-classic. Reviewed-by: Emma Anholt <emma@anholt.net> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Acked-by: Jason Ekstrand <jason@jlekstrand.net> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10153>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 4 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 23b17a3e2ac..e67b45d7d9e 100644
--- a/meson.build
+++ b/meson.build
@@ -562,16 +562,12 @@ endif
if with_glx != 'disabled'
if not (with_platform_x11 and with_any_opengl)
error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
- elif with_glx == 'gallium-xlib'
+ elif with_glx == 'xlib'
if not with_gallium
- error('Gallium-xlib based GLX requires at least one gallium driver')
+ error('xlib based GLX requires at least one gallium driver')
elif not with_gallium_softpipe
- error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
+ error('xlib based GLX requires softpipe or llvmpipe.')
elif with_dri
- error('gallium-xlib conflicts with any dri driver')
- endif
- elif with_glx == 'xlib'
- if with_dri
error('xlib conflicts with any dri driver')
endif
elif with_glx == 'dri'
@@ -586,7 +582,7 @@ glvnd_vendor_name = get_option('glvnd-vendor-name')
if with_glvnd
if with_platform_windows
error('glvnd cannot be used on Windows')
- elif with_glx == 'xlib' or with_glx == 'gallium-xlib'
+ elif with_glx == 'xlib'
error('Cannot build glvnd support for GLX that is not DRI based.')
elif with_glx == 'disabled' and not with_egl
error('glvnd requires DRI based GLX and/or EGL')
@@ -2246,8 +2242,6 @@ if with_glx != 'disabled'
lines += 'GLX: DRI-based'
elif with_glx == 'xlib'
lines += 'GLX: Xlib-based'
- elif with_glx == 'gallium-xlib'
- lines += 'GLX: Xlib-based (Gallium)'
else
lines += 'GLX: ' + with_glx
endif