summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2021-11-25 21:51:07 +0100
committerMarge Bot <emma+marge@anholt.net>2021-12-16 17:19:28 +0000
commit631b3fe3e9e27302d48051f7d5bef5e4e1bb0e40 (patch)
tree6e222eeb45d1c66ea3ca7521abff93401562561a /meson.build
parent7a22967de310069fe7be2a5e144fb677baaa071d (diff)
meson: correctly detect linker arguments
Fixes: 22673a98 ("meson: Check arguments before adding") Reviewed-by: Emma Anholt <emma@anholt.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13961>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 07ef92dbff8..03dda9ee3e7 100644
--- a/meson.build
+++ b/meson.build
@@ -1210,7 +1210,7 @@ if host_machine.system() == 'windows'
endif
else
add_project_link_arguments(
- cc.get_supported_arguments(
+ cc.get_supported_link_arguments(
'-Wl,--nxcompat',
'-Wl,--dynamicbase',
'-static-libgcc',
@@ -1219,7 +1219,7 @@ if host_machine.system() == 'windows'
language : ['c'],
)
add_project_link_arguments(
- cpp.get_supported_arguments(
+ cpp.get_supported_link_arguments(
'-Wl,--nxcompat',
'-Wl,--dynamicbase',
'-static-libgcc',