summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2021-12-06 20:16:19 +0100
committerMarge Bot <emma+marge@anholt.net>2021-12-07 22:24:52 +0000
commit558bc2227ed00fc6a29c2a10c0b99719cd445c6c (patch)
tree446529deff512564580bbe6f753ba5e166945ba5 /meson.build
parentdef254b05ff999cd0e1b2723cd0757165ebae421 (diff)
meson: check -mtls if has_exe_wrapper
Fixes: 60d95c5d (Auto-enable TLSDESC support) Reviewed-by: Emma Anholt <emma@anholt.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14086>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53ec2c2ef95..c987073b537 100644
--- a/meson.build
+++ b/meson.build
@@ -502,7 +502,7 @@ endforeach
if not have_mtls_dialect
# need .run to check libc support. meson aborts when calling .run when
# cross-compiling, but because this is just an optimization we can skip it
- if meson.is_cross_build()
+ if meson.is_cross_build() and not meson.has_exe_wrapper()
warning('cannot auto-detect -mtls-dialect when cross-compiling, using compiler default')
else
# -fpic to force dynamic tls, otherwise TLS relaxation defeats check