summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJuan A. Suarez Romero <jasuarez@igalia.com>2022-03-14 18:47:37 +0100
committerJuan A. Suarez Romero <jasuarez@igalia.com>2022-03-17 11:15:53 +0100
commit54d0a2cfad3352750dedf4851a6f097c5e507c3d (patch)
tree34413c0cb95f71ed7ced2fbbb0b7e8373d4b5864 /meson.build
parent6d7f04e5de66a6463464dd7843db16fe8dc3c6aa (diff)
util/disk_cache: rename MESA_GLSL_CACHE envvar
Rename MESA_GLSL_CACHE to MESA_SHADER_CACHE, as the on-disk cache can store not only GLSL but also SPIR-V shaders. v2: - Keep old envvar as deprecated (Mike) Signed-off-by: Juan A. Suarez Romero <jasuarez@igalia.com> Reviewed-by: Timothy Arceri <tarceri@itsqueeze.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15390>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index cbe8edce334..8ab5627fed1 100644
--- a/meson.build
+++ b/meson.build
@@ -1045,7 +1045,7 @@ endif
if with_shader_cache
shader_cache_max_size = get_option('shader-cache-max-size')
if shader_cache_max_size != ''
- pre_args += '-DMESA_GLSL_CACHE_MAX_SIZE="@0@"'.format(shader_cache_max_size)
+ pre_args += '-DMESA_SHADER_CACHE_MAX_SIZE="@0@"'.format(shader_cache_max_size)
endif
endif