summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2021-10-09 11:31:24 +0100
committerMarge Bot <emma+marge@anholt.net>2021-11-08 18:35:28 +0000
commit448dd106da2e4751d88131e58e097ef06638154c (patch)
treeb8eb1581a42c2060e40601f23d20ac74b5098c1a /meson.build
parent2351c0aded860f4769dde73a50a287a670f2ad3c (diff)
meson: drop impossible `if no platform` branch
We've already ensured a few lines above that there is at least `surfaceless` in the list. Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13278>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 59cee728070..4fb4cfc5555 100644
--- a/meson.build
+++ b/meson.build
@@ -487,11 +487,7 @@ if with_egl
egl_native_platform = get_option('egl-native-platform')
if egl_native_platform.contains('auto')
- if _platforms.length() != 0
- egl_native_platform = _platforms[0]
- else
- egl_native_platform = 'surfaceless'
- endif
+ egl_native_platform = _platforms[0]
endif
endif