summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChad Versace <chad@kiwitree.net>2022-03-28 12:51:03 -0700
committerMarge Bot <emma+marge@anholt.net>2022-03-31 18:20:01 +0000
commit3f8224baeead17338fdd593b8fe1c23e436e10a5 (patch)
tree36ffee38ee0795935b111039eeded79f7cd167da /meson.build
parentd5405c16084da1c2e64b04536be880302dee98cd (diff)
intel/tools: Fix build without drivers
If Meson was configured with -Dtools=intel but all Intel drivers were disabled, then Meson silently refused to build the tools. Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15617>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c9cded59d51..b6a2a9dca99 100644
--- a/meson.build
+++ b/meson.build
@@ -280,7 +280,7 @@ with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
with_any_vk = _vulkan_drivers.length() != 0
with_any_broadcom = with_gallium_vc4 or with_gallium_v3d or with_broadcom_vk
-with_any_intel = with_intel_vk or with_gallium_iris or with_gallium_crocus
+with_any_intel = with_intel_vk or with_gallium_iris or with_gallium_crocus or with_intel_tools
if with_swrast_vk and not with_gallium_softpipe
error('swrast vulkan requires gallium swrast')