summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJesse Natalie <jenatali@microsoft.com>2021-08-04 17:55:58 -0700
committerMarge Bot <emma+marge@anholt.net>2021-11-19 21:21:35 +0000
commit33e5a4378efee353ddadf103300ab27ed4dc32c7 (patch)
tree70937c3523ff09dbe1c72f409c217c628f2ef34a /meson.build
parent6138b047e294db910d16da63e2e7280e55823899 (diff)
android,d3d12: Support using DirectX-Headers dependency from AOSP
Note that the Android build system apparently lowercases stuff, so add a lowercase "directx-headers" dependency which is searched first, before falling back to the proper-cased "DirectX-Headers" dependency. Reviewed-by: Roman Stratiienko <r.stratiienko@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/13532>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fa37127612c..cf2b5f4b939 100644
--- a/meson.build
+++ b/meson.build
@@ -648,9 +648,12 @@ endif
dep_dxheaders = null_dep
if with_gallium_d3d12 or with_microsoft_clc
- dep_dxheaders = dependency('DirectX-Headers', fallback : ['DirectX-Headers', 'dep_dxheaders'],
- required : with_gallium_d3d12
- )
+ dep_dxheaders = dependency('directx-headers', required : false)
+ if not dep_dxheaders.found()
+ dep_dxheaders = dependency('DirectX-Headers', fallback : ['DirectX-Headers', 'dep_dxheaders'],
+ required : with_gallium_d3d12
+ )
+ endif
endif
if with_vulkan_overlay_layer or with_aco_tests