summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Jackson <ajax@redhat.com>2022-03-24 15:05:32 -0400
committerMarge Bot <emma+marge@anholt.net>2022-04-07 00:17:40 +0000
commit25c42abac8172266e6d02a2e2220b0a5c8a53dad (patch)
tree85a9bd6e9e4bebef6427954115c52eff48d9caa1 /meson.build
parent3883ca5ea703b88f6e1709adab845c31e0c5220c (diff)
meson: Define a HAVE_XXXX macro for every gallium driver we build
Reviewed-by: Mike Blumenkrantz <michael.blumenkrantz@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14541>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b6a2a9dca99..189a5c51ec4 100644
--- a/meson.build
+++ b/meson.build
@@ -231,6 +231,9 @@ with_gallium_lima = gallium_drivers.contains('lima')
with_gallium_zink = gallium_drivers.contains('zink')
with_gallium_d3d12 = gallium_drivers.contains('d3d12')
with_gallium_asahi = gallium_drivers.contains('asahi')
+foreach gallium_driver : gallium_drivers
+ pre_args += '-DHAVE_@0@'.format(gallium_driver.to_upper())
+endforeach
with_gallium = gallium_drivers.length() != 0
with_gallium_kmsro = with_gallium_v3d or with_gallium_vc4 or with_gallium_etnaviv or with_gallium_panfrost or with_gallium_lima or with_gallium_freedreno