summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-12-02 18:34:56 -0500
committerMarge Bot <emma+marge@anholt.net>2022-01-19 19:45:22 +0000
commit19f88eb858ef09085be7f6301b52a3ac769d0b91 (patch)
treef4a52119785aac0d696115642a4a1f92769ac94e /meson.build
parent96cc3007461a837042fc1bb3adf11356638efdcd (diff)
meson: tlsdesc: minor reformatting, add comments
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14027>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 50d067984ca..07f681ad5d8 100644
--- a/meson.build
+++ b/meson.build
@@ -516,10 +516,13 @@ if not have_mtls_dialect
warning('cannot auto-detect -mtls-dialect when cross-compiling, using compiler default')
else
# -fpic to force dynamic tls, otherwise TLS relaxation defeats check
- gnu2_test = cc.run('int __thread x; int main() { return x; }', args: ['-mtls-dialect=gnu2', '-fpic'], name: '-mtls-dialect=gnu2')
+ gnu2_test = cc.run('int __thread x; int main() { return x; }',
+ args: ['-mtls-dialect=gnu2', '-fpic'],
+ name: '-mtls-dialect=gnu2')
if gnu2_test.returncode() == 0 and (
+ # check for lld 13 bug: https://gitlab.freedesktop.org/mesa/mesa/-/issues/5665
host_machine.cpu_family() != 'x86_64' or
- # https://github.com/mesonbuild/meson/issues/6377
+ # get_linker_id misses LDFLAGS=-fuse-ld=lld: https://github.com/mesonbuild/meson/issues/6377
#cc.get_linker_id() != 'ld.lld' or
cc.links('''int __thread x; int y; int main() { __asm__(
"leaq x@TLSDESC(%rip), %rax\n"