summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan.c.baker@intel.com>2021-04-09 10:00:44 -0700
committerMarge Bot <emma+marge@anholt.net>2021-12-03 23:53:06 +0000
commit0cad451f007f366d94e058b7c717b96723a3e6cd (patch)
treeeab4b3bbcf2e89b04cda03518898814e3871f60c /meson.build
parentf464871932882003e01e3459c8d126dd975d60f8 (diff)
classic/i915: Remove driver
This is only going to be supported in the Amber branch Reviewed-by: Emma Anholt <emma@anholt.net> Acked-by: Jason Ekstrand <jason@jlekstrand.net> Acked-by: Kenneth Graunke <kenneth@whitecape.org> Reviewed-by: Adam Jackson <ajax@redhat.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10153>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 0019331b7e6..03830e4a9ad 100644
--- a/meson.build
+++ b/meson.build
@@ -178,7 +178,7 @@ if dri_drivers.contains('auto')
if system_has_kms_drm
# TODO: PPC, Sparc
if ['x86', 'x86_64'].contains(host_machine.cpu_family())
- dri_drivers = ['i915', 'i965']
+ dri_drivers = ['i965']
elif ['arm', 'aarch64', 'mips', 'mips64'].contains(host_machine.cpu_family())
dri_drivers = []
else
@@ -194,7 +194,6 @@ if dri_drivers.contains('auto')
endif
endif
-with_dri_i915 = dri_drivers.contains('i915')
with_dri_i965 = dri_drivers.contains('i965')
with_dri = dri_drivers.length() != 0
@@ -299,9 +298,6 @@ with_any_intel = with_dri_i965 or with_intel_vk or with_gallium_iris or with_gal
if with_swrast_vk and not with_gallium_softpipe
error('swrast vulkan requires gallium swrast')
endif
-if with_dri_i915 and with_gallium_i915
- error('Only one i915 provider can be built')
-endif
if with_gallium_tegra and not with_gallium_nouveau
error('tegra driver requires nouveau driver')
endif
@@ -1591,7 +1587,7 @@ _drm_intel_ver = '2.4.75'
_drm_ver = '2.4.109'
_libdrm_checks = [
- ['intel', with_dri_i915 or with_gallium_i915],
+ ['intel', with_gallium_i915],
['amdgpu', (with_amd_vk and not with_platform_windows) or with_gallium_radeonsi],
['radeon', (with_gallium_radeonsi or with_gallium_r300 or with_gallium_r600)],
['nouveau', with_gallium_nouveau],