summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-04-01 10:14:54 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-04-03 09:41:24 -0700
commit4c332a1f9fa60fe0e587a07b7265766ed136e5ea (patch)
tree20b14c5e8c1001926cebd7e910a12f38482f576d /meson.build
parent29912f2ea486fb8ffbc98db347679cf542422efe (diff)
meson: Error if LLVM is turned off but clover it turned on
Since clover has a hard requirement on LLVM v2: - make error message more specific Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 46541254fb8..917186a4f0b 100644
--- a/meson.build
+++ b/meson.build
@@ -1260,6 +1260,8 @@ if with_llvm
endif
elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
+elif with_gallium_opencl
+ error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
endif
if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or