summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRob Herring <robh@kernel.org>2019-01-24 14:03:54 -0600
committerRob Herring <robh@kernel.org>2019-01-28 11:50:08 -0600
commit41a0acd6a149ec9f47ea527ad08a2b29bf1ee6b2 (patch)
tree8f57c50d50b6a77160345439d33f2a47241f31fc /meson.build
parent827e0d6654a2dba0c2090abde84ccef8c8d8ec7e (diff)
Switch imx to kmsro and remove the imx winsys
The kmsro winsys is equivalent to the imx winsys, so we can switch to it and remove the imx one. Signed-off-by: Rob Herring <robh@kernel.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 344140d6a4a..81f50ba6c3c 100644
--- a/meson.build
+++ b/meson.build
@@ -131,7 +131,7 @@ if _drivers.contains('auto')
]
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
_drivers = [
- 'kmsro', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'imx', 'nouveau',
+ 'kmsro', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'nouveau',
'tegra', 'virgl', 'swrast',
]
else
@@ -155,7 +155,6 @@ with_gallium_softpipe = _drivers.contains('swrast')
with_gallium_vc4 = _drivers.contains('vc4')
with_gallium_v3d = _drivers.contains('v3d')
with_gallium_etnaviv = _drivers.contains('etnaviv')
-with_gallium_imx = _drivers.contains('imx')
with_gallium_tegra = _drivers.contains('tegra')
with_gallium_i915 = _drivers.contains('i915')
with_gallium_svga = _drivers.contains('svga')
@@ -210,9 +209,6 @@ endif
if with_dri_i915 and with_gallium_i915
error('Only one i915 provider can be built')
endif
-if with_gallium_imx and not with_gallium_etnaviv
- error('IMX driver requires etnaviv driver')
-endif
if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv)
error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv)')
endif