summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-10-07 18:46:41 -0700
committerEric Engestrom <eric.engestrom@intel.com>2019-10-16 13:45:57 +0100
commitd8a9420f6f1a9eabe6dffe19779de9ec8fba9ab0 (patch)
tree3dd65f0dacad1729ffee2444a4fa1d221cc35672 /meson.build
parent7040795a69a400b32ca17d78c8142976c66a1a97 (diff)
meson: recognize "sunos" as the system name for Solaris
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Acked-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e1ca9559b56..e65dcf482aa 100644
--- a/meson.build
+++ b/meson.build
@@ -124,7 +124,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
with_shared_glapi = with_shared_glapi and with_any_opengl
-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux'].contains(host_machine.system())
+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos'].contains(host_machine.system())
dri_drivers = get_option('dri-drivers')
if dri_drivers.contains('auto')
@@ -885,6 +885,8 @@ endif
# TODO: this is very incomplete
if ['linux', 'cygwin', 'gnu', 'gnu/kfreebsd'].contains(host_machine.system())
pre_args += '-D_GNU_SOURCE'
+elif host_machine.system() == 'sunos'
+ pre_args += '-D__EXTENSIONS__'
elif host_machine.system() == 'windows'
pre_args += [
'-D_WINDOWS', '-D_WIN32_WINNT=0x0601', '-D_WINVER=0x0601',