summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-05-17 14:45:10 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-10-10 16:33:04 -0700
commitd2cb0a59cedbc9f7b54b68c36e025f0c948ad846 (patch)
treeffdafcb7241453329a7357960d79807bbf96c1f3 /meson.build
parent150aec5d1f2ed6599eabbda5e92354d6846dc0bc (diff)
meson: disable sse4.1 optimizations with msvc
There isn't an obvious command line switch here, /arch:AVX *might* be the right thing, but meson doesn't know what to do here either and leaves the -msse4.1 and -mstackrealign. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Kristian H. Kristensen <hoegsberg@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b823dd8ecec..cfa77db1a1a 100644
--- a/meson.build
+++ b/meson.build
@@ -1027,7 +1027,7 @@ if host_machine.system() == 'windows'
endif
endif
-if host_machine.cpu_family().startswith('x86')
+if host_machine.cpu_family().startswith('x86') and cc.get_id() != 'msvc'
pre_args += '-DUSE_SSE41'
with_sse41 = true
sse41_args = ['-msse4.1']