summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2019-11-11 22:14:55 +0100
committerMichel Zou <xantares09@hotmail.com>2019-11-23 12:01:11 +0100
commitbfd9f3201e49cd3f46393b7737cd156a69e9f5ab (patch)
tree6dcb4e6456aed7e08641a8be77bb08679be9cac7 /meson.build
parentad40715f3595537cfcc3d489f86d6c4dd7f34cc6 (diff)
Meson: Check for dladdr with MinGW
Reviewed-by: Eric Engestrom <eric@engestrom.ch>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 6 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 39907709f71..69d15649060 100644
--- a/meson.build
+++ b/meson.build
@@ -1223,14 +1223,12 @@ ld_args_build_id = cc.get_supported_link_arguments('-Wl,--build-id=sha1')
# check for dl support
dep_dl = null_dep
-if host_machine.system() != 'windows'
- if not cc.has_function('dlopen')
- dep_dl = cc.find_library('dl')
- endif
- if cc.has_function('dladdr', dependencies : dep_dl)
- # This is really only required for megadrivers
- pre_args += '-DHAVE_DLADDR'
- endif
+if not cc.has_function('dlopen')
+ dep_dl = cc.find_library('dl', required : host_machine.system() != 'windows')
+endif
+if cc.has_function('dladdr', dependencies : dep_dl)
+ # This is really only required for megadrivers
+ pre_args += '-DHAVE_DLADDR'
endif
if cc.has_function('dl_iterate_phdr')