summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-10-18 13:49:42 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-10-21 17:21:57 +0000
commita9a9249288c3abfb52bcce3f88f8b4bbb92017e4 (patch)
tree0e1632bf50e00ca5a8e9837726b433e0cd9af749 /meson.build
parentd33fe2d5ebdc580d188c305a266df19213ed6403 (diff)
meson: Require meson >= 0.49.1 when using icc or icl
0.49.0 can compile most of mesa with ICC or ICL, but not SWR without additional workarounds in our meson.build files. Bumping patch version is easier and shouldn't be a big burden anyway, especially to cover a niche compiler. The check originally only covered ICC, but now covers ICL as well. Fixes: 3740ffb59c89d8d879b1e0c1aed32c389dd82a35 ("meson: add switches for SWR with MSVC") Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/1937 Acked-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 00cf3e017ab..b4cd7999566 100644
--- a/meson.build
+++ b/meson.build
@@ -199,12 +199,8 @@ with_gallium_virgl = gallium_drivers.contains('virgl')
with_gallium_swr = gallium_drivers.contains('swr')
with_gallium_lima = gallium_drivers.contains('lima')
-if cc.get_id() == 'intel'
- if meson.version().version_compare('< 0.49.0')
- error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
- elif with_gallium_swr and meson.version().version_compare('== 0.49.0')
- warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
- endif
+if cc.get_id().startswith('intel') and meson.version().version_compare('< 0.49.1')
+ error('Meson does not have sufficient support of ICC before 0.49.1 to compile mesa')
endif
with_gallium = gallium_drivers.length() != 0 and gallium_drivers != ['']