summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-05-22 14:08:36 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-10-10 16:33:04 -0700
commit8eee724b7352d066a8ce6f5401ca7ac8c6f778a8 (patch)
tree6ca4d90866b1210bcb4b9d65eefdb9e4c4c888fa /meson.build
parent3740ffb59c89d8d879b1e0c1aed32c389dd82a35 (diff)
meson: don't define USE_ELF_TLS for windows
Because the macros for exporting dll symbols and using TLS are mutually exclusive. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Kristian H. Kristensen <hoegsberg@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index cfa77db1a1a..781a21cf2ee 100644
--- a/meson.build
+++ b/meson.build
@@ -390,7 +390,7 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
-if not with_platform_android or get_option('platform-sdk-version') >= 29
+if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
pre_args += '-DUSE_ELF_TLS'
endif