summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorErik Faye-Lund <erik.faye-lund@collabora.com>2018-08-31 16:50:20 +0200
committerErik Faye-Lund <erik.faye-lund@collabora.com>2019-10-28 08:51:43 +0000
commit8d46e35d16e3936968958bcab86d61967a673305 (patch)
tree340ebb375451698e95c55ff577fc0e4412d803f2 /meson.build
parent59127925010bfbab09e0c22a41ce77b334f59942 (diff)
zink: introduce opengl over vulkan
Here's zink, a so far pretty simple vulkan-gallium driver that is able to translate some applications from OpenGL to Vulkan. The compiler is quite limited for now, this will be improved on later. Signed-off-by: Erik Faye-Lund <erik.faye-lund@collabora.com> Acked-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ac864819013..180401c9a23 100644
--- a/meson.build
+++ b/meson.build
@@ -198,6 +198,7 @@ with_gallium_svga = gallium_drivers.contains('svga')
with_gallium_virgl = gallium_drivers.contains('virgl')
with_gallium_swr = gallium_drivers.contains('swr')
with_gallium_lima = gallium_drivers.contains('lima')
+with_gallium_zink = gallium_drivers.contains('zink')
if cc.get_id().startswith('intel') and meson.version().version_compare('< 0.49.1')
error('Meson does not have sufficient support of ICC before 0.49.1 to compile mesa')
@@ -491,6 +492,10 @@ if vdpau_drivers_path == ''
vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
endif
+if with_gallium_zink
+ dep_vulkan = dependency('vulkan')
+endif
+
_xvmc = get_option('gallium-xvmc')
if not system_has_kms_drm
if _xvmc == 'true'