summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVinson Lee <vlee@freedesktop.org>2019-09-04 22:17:25 -0700
committerVinson Lee <vlee@freedesktop.org>2019-09-11 15:14:17 -0700
commit8d286776b6ca177a5e55a9c706081a40ebbcf091 (patch)
tree9066952138c2a68f6f173e2ef54d715d47c945f2 /meson.build
parent272f9cfe6a19212354c89dc443959473ac5d398e (diff)
meson: Add coroutines component to llvmpipe build.
Fixes: d32690b43c91 ("gallivm: add coroutine pass manager support") Suggested-by: Gert Wollny <gert.wollny@collabora.com> Signed-off-by: Vinson Lee <vlee@freedesktop.org> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b8c19999f01..29d7981d13d 100644
--- a/meson.build
+++ b/meson.build
@@ -1254,6 +1254,8 @@ if with_gallium_opencl
'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
'lto', 'option', 'objcarcopts', 'profiledata',
]
+endif
+if with_gallium_opencl or with_gallium_softpipe
llvm_optional_modules += ['coroutines']
endif