summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-10-29 21:43:22 +0000
committerEric Engestrom <eric.engestrom@intel.com>2019-11-05 20:56:44 +0000
commit66dd53584e223f1e83e24349f26c7d9a4812faa3 (patch)
treec0d85cf22316c330a6fcb3fbaa797a5d3e9ce9a0 /meson.build
parent4d5cde1fffc4f1c61a58164a619466371948b704 (diff)
meson: require `nm` again on Unix systems
This was made optional in ff9bf223c24143260a97 ("meson: make nm binary optional") for Windows, but proper windows has been added and `nm` is now only used on Unix systems. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviwed-by: Dylan Baker <dylan@pnwbakers>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 796b628e5eb..457cc0c5fdc 100644
--- a/meson.build
+++ b/meson.build
@@ -1685,8 +1685,8 @@ if host_machine.system() == 'windows'
with_symbols_check = prog_dumpbin.found() and with_tests
symbols_check_args = ['--dumpbin', prog_dumpbin.path()]
else
- prog_nm = find_program('nm', required : false)
- with_symbols_check = prog_nm.found() and with_tests
+ prog_nm = find_program('nm')
+ with_symbols_check = with_tests
symbols_check_args = ['--nm', prog_nm.path()]
endif