summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2019-12-28 22:51:39 +0100
committerMarge Bot <eric+marge@anholt.net>2020-01-22 23:15:05 +0000
commit2fd85105c6b144d1f44e5faef33363e554b58455 (patch)
tree3061ae1db98e6a52a70b68ae4434668801e86cb0 /meson.build
parent4f52425159b057442cc7b83eb26590479db05067 (diff)
meson: Do not require libdrm for DRI2 on hurd
Cc: 19.3 <mesa-stable@lists.freedesktop.org> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Signed-off-by: Samuel Thibault <samuel.thibault@ens-lyon.org> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3231> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3231>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2cf0ee7fe0c..c48945b3c48 100644
--- a/meson.build
+++ b/meson.build
@@ -436,6 +436,7 @@ if with_vulkan_icd_dir == ''
with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif
+# GNU/Hurd includes egl_dri2, without drm.
with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
host_machine.system() == 'gnu')
_dri3 = get_option('dri3')
@@ -1358,7 +1359,8 @@ endforeach
with_gallium_drisw_kms = false
dep_libdrm = dependency(
'libdrm', version : '>=' + _drm_ver,
- required : with_dri2 or with_dri3
+ # GNU/Hurd includes egl_dri2, without drm.
+ required : (with_dri2 and host_machine.system() != 'gnu') or with_dri3
)
if dep_libdrm.found()
pre_args += '-DHAVE_LIBDRM'