summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-10-29 21:32:05 +0000
committerEric Engestrom <eric.engestrom@intel.com>2019-11-05 20:30:47 +0000
commit2f652e0b3691e94d6a81e37985741d35561b2312 (patch)
treee09619cadc2a60908b8851b93466cc838d9d2a42 /meson.build
parent2c4395e61c4c090a85f21d57f2d670b5cd59795a (diff)
meson: move the generic symbols check arguments to a common variable
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviwed-by: Dylan Baker <dylan@pnwbakers>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dcc4827fed7..020f725116f 100644
--- a/meson.build
+++ b/meson.build
@@ -1682,6 +1682,7 @@ pkg = import('pkgconfig')
prog_nm = find_program('nm', required : false)
with_symbols_check = prog_nm.found() and with_tests
+symbols_check_args = ['--nm', prog_nm.path()]
# This quirk needs to be applied to sources with functions defined in assembly
# as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391