summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2017-12-07 16:03:40 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2018-03-20 16:57:23 +0000
commitb33937ab13bbe5cb5bca7e20604499d0fd5bda36 (patch)
treeb52f146e93cde7c4e2b9700b5feb6478a4c38ae6 /meson.build
parenta731133c91fcb29233c9883760340eba10c98c71 (diff)
meson: dedup gallium-xa logic
Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> (cherry picked from commit 2f0db33527fc5415858e60d76d5b82c5492151fa)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 10 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index 08adc952171..855db70dd0f 100644
--- a/meson.build
+++ b/meson.build
@@ -550,26 +550,21 @@ if va_drivers_path == ''
endif
_xa = get_option('gallium-xa')
-if _xa == 'auto'
- if not system_has_kms_drm
- with_gallium_xa = false
- elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
- or with_gallium_svga)
- with_gallium_xa = false
+if not system_has_kms_drm
+ if _xa == 'true'
+ error('XA state tracker can only be built on unix-like OSes.')
else
- with_gallium_xa = true
+ _xa = 'false'
endif
-elif _xa == 'true'
- if not system_has_kms_drm
- error('XA state tracker can only be built on DRM/KMS OSes.')
- elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
- or with_gallium_svga)
+elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
+ or with_gallium_svga)
+ if _xa == 'true'
error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
+ else
+ _xa = 'false'
endif
- with_gallium_xa = true
-else
- with_gallium_xa = false
endif
+with_gallium_xa = _xa != 'false'
d3d_drivers_path = get_option('d3d-drivers-path')
if d3d_drivers_path == ''