summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRob Herring <robh@kernel.org>2019-01-25 10:39:40 -0600
committerQiang Yu <yuq825@gmail.com>2019-04-11 09:57:53 +0800
commitb1da1946c75bdf5d6bd27bfcec3354028808aacb (patch)
tree8a54278488f3bf01c35e27f0467fce1b2f79071b /meson.build
parent92d7ca4b1cdfe1ffc80748fa7eedf927f3c664f0 (diff)
kmsro: Add lima renderonly support
Enable using lima for KMS renderonly. This still needs KMS driver name mapping to kmsro to be used automatically. Reviewed-by: Eric Anholt <eric@anholt.net> Signed-off-by: Rob Herring <robh@kernel.org> Signed-off-by: Qiang Yu <yuq825@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ae52ac137c0..0e8aa25d336 100644
--- a/meson.build
+++ b/meson.build
@@ -217,8 +217,8 @@ endif
if with_dri_i915 and with_gallium_i915
error('Only one i915 provider can be built')
endif
-if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost)
- error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost)')
+if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
+ error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost, lima)')
endif
if with_gallium_tegra and not with_gallium_nouveau
error('tegra driver requires nouveau driver')