summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-12-04 10:06:08 -0800
committerEmil Velikov <emil.l.velikov@gmail.com>2019-01-11 19:19:08 +0000
commit336c7bf5971c97949de8ca14537dce62c5ac5937 (patch)
tree0a7847822a4a2c617d2ec46b81f4e3d01fe12edd /meson.build
parent40c012a5aa39dddaab34b25a91db5b1bb89fb369 (diff)
meson: Add toggle for glx-direct
GNU Hurd needs to turn off glx-direct, rather than special case it, we'll just add a toggle. CC: 18.3 <mesa-stable@lists.freedesktop.org> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> (cherry picked from commit 7a90886921eb1d5d73b40aadd6fd3f340041bd26)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 5045dca0149..2fa861bae2a 100644
--- a/meson.build
+++ b/meson.build
@@ -54,6 +54,7 @@ with_valgrind = get_option('valgrind')
with_libunwind = get_option('libunwind')
with_asm = get_option('asm')
with_glx_read_only_text = get_option('glx-read-only-text')
+with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
@@ -368,9 +369,6 @@ if with_glvnd
endif
endif
-# TODO: toggle for this
-with_glx_direct = true
-
if with_vulkan_icd_dir == ''
with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif