summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-12-05 09:40:03 -0800
committerDylan Baker <dylan@pnwbakers.com>2017-12-07 10:22:27 -0800
commitc34b53f13326c89e09447d759ee188fe9c4964d8 (patch)
tree2dd8303c0e49262260fde3d2703b22279d6e0c98 /meson.build
parent2adc3817c6e9884ce5354be079d566b48410f642 (diff)
meson: Fix building gallium media targets with gallium-xlib glx
To demonstrate this bug run meson with the options: -Ddri-drivers= -Dglx=gallium-xlib Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 1ea63fb1291..6e5ae4d24e9 100644
--- a/meson.build
+++ b/meson.build
@@ -1110,9 +1110,9 @@ if with_platform_x11
dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
dep_xxf86vm = dependency('xxf86vm', required : false)
endif
- if with_any_vk or with_glx == 'dri' or
- (with_gallium_vdpau or with_gallium_xvmc or with_gallium_omx or
- with_gallium_xa)
+ if (with_any_vk or with_glx == 'dri' or
+ (with_gallium_vdpau or with_gallium_xvmc or with_gallium_omx or
+ with_gallium_xa))
dep_xcb = dependency('xcb')
dep_x11_xcb = dependency('x11-xcb')
endif