summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-09-28 21:03:07 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-16 16:32:43 -0700
commitaf9d276134d9af3b6145f10943eaf7bf1a6226b6 (patch)
treee239a07620e73a1769b3e6ad23b84351c284d9f1 /meson.build
parent02cf3a8f39ebdc7f7cbf0b2960744cae1a865f46 (diff)
meson: build libmesa_gallium
Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 15 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index ff2ce55e924..0ffa280b7e4 100644
--- a/meson.build
+++ b/meson.build
@@ -90,12 +90,17 @@ if _drivers != ''
with_dri = true
endif
-dep_libdrm_intel = []
-if with_dri_i915
- dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
+with_gallium = false
+with_gallium_radeonsi = false
+_drivers = get_option('gallium-drivers')
+if _drivers != ''
+ _split = _drivers.split(',')
+ with_gallium_radeonsi = _split.contains('radeonsi')
+ with_gallium = true
+ with_dri = true
endif
-if not with_dri
+if not (with_dri or with_gallium)
with_gles1 = false
with_gles2 = false
with_opengl = false
@@ -103,12 +108,14 @@ if not with_dri
with_shared_glapi = false
endif
+dep_libdrm_intel = []
+if with_dri_i915
+ dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
+endif
+
# TODO: other OSes
with_dri_platform = 'drm'
-with_gallium = false
-# TODO: gallium drivers
-
# TODO: conditionalize libdrm requirement
dep_libdrm = dependency('libdrm', version : '>= 2.4.75')
pre_args += '-DHAVE_LIBDRM'
@@ -207,7 +214,7 @@ if _vulkan_drivers != ''
endif
endif
-if with_dri # TODO: or gallium
+if with_dri or with_gallium
if with_glx == 'disabled' # TODO: or egl
error('building dri or gallium drivers require at least one window system')
endif
@@ -564,8 +571,6 @@ dep_selinux = []
# TODO: flags for xa, egl, gbm, nin, xvmc, vdpau, omx, va, opencl,
# gallium-tests,
-# TODO: gallium drivers
-
# TODO: symbol mangling
# TODO: egl configuration