summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2017-11-23 13:40:06 +0000
committerJon Turney <jon.turney@dronecode.org.uk>2017-11-30 15:09:21 +0000
commit9cdd41b18ae268d8ef99dbd766f4cb85c0ee315e (patch)
tree807cf0c308a7d0dde632c87beea7e7cecd049585 /meson.build
parentbb5d663b3908de1ef173df8341b283dd00b8123b (diff)
meson: set windows glx defines
Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4a2e817f0fa..a7a51bccb33 100644
--- a/meson.build
+++ b/meson.build
@@ -392,6 +392,8 @@ if with_platform_x11
endif
if with_dri_platform == 'drm'
pre_args += '-DGLX_USE_DRM'
+ elif with_dri_platform == 'windows'
+ pre_args += '-DGLX_USE_WINDOWSGL'
endif
endif
else