summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-25 16:54:53 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-28 14:06:26 -0800
commit9169dde94149abe519cf1d1da7e388d0e200fa3f (patch)
tree0d04380abc3f172a704014ffa76d3849ce3e4708 /meson.build
parentc5d199fa2ca612acd22f7ff2fc584b9110bbbd44 (diff)
meson: build i915g driver
Build tested only. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53013e47ec4..b40b71c5e84 100644
--- a/meson.build
+++ b/meson.build
@@ -119,6 +119,7 @@ with_gallium_vc4 = false
with_gallium_vc5 = false
with_gallium_etnaviv = false
with_gallium_imx = false
+with_gallium_i915 = false
_drivers = get_option('gallium-drivers')
if _drivers == 'auto'
if not ['darwin', 'windows'].contains(host_machine.system())
@@ -145,6 +146,7 @@ if _drivers != ''
with_gallium_vc5 = _split.contains('vc5')
with_gallium_etnaviv = _split.contains('etnaviv')
with_gallium_imx = _split.contains('imx')
+ with_gallium_i915 = _split.contains('i915')
with_gallium = true
endif
@@ -174,12 +176,15 @@ endif
if with_dri_swrast and with_gallium_softpipe
error('Only one swrast provider can be built')
endif
+if with_dri_i915 and with_gallium_i915
+ error('Only one i915 provider can be built')
+endif
if with_gallium_imx and not with_gallium_etnaviv
error('IMX driver requires etnaviv driver')
endif
dep_libdrm_intel = []
-if with_dri_i915
+if with_dri_i915 or with_gallium_i915
dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
endif