summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-01-08 17:43:45 -0800
committerDylan Baker <dylan@pnwbakers.com>2018-01-08 17:43:45 -0800
commit73ce7cb47406ec3e0fd56945dc66f7e258187630 (patch)
treee168968fb46961f62719cc29c3ee27ecd1a80148 /meson.build
parent21bca27349e8e356c91cab8a20a034931002181b (diff)
Meson: ensure variable defined
A gallium driver is undefined if passing -Dgallium-drivers='' Fixes: e0b037d6979b2 ("meson: Build SWR driver") Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Acked-by: Jordan Justen <jordan.l.justen@intel.com> Acked-by: Jason Ekstrand <jason.ekstrand@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1a1d3fd69b9..77e4e894b23 100644
--- a/meson.build
+++ b/meson.build
@@ -125,6 +125,7 @@ with_gallium_imx = false
with_gallium_i915 = false
with_gallium_svga = false
with_gallium_virgl = false
+with_gallium_swr = false
_drivers = get_option('gallium-drivers')
if _drivers == 'auto'
if not ['darwin', 'windows'].contains(host_machine.system())