summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2017-11-23 13:51:43 +0000
committerJon Turney <jon.turney@dronecode.org.uk>2017-11-30 15:09:21 +0000
commit6f0ce2617eee17215b797f8037f71df279697bbd (patch)
tree7cbf72e8f837a07963b2dfa4664ea05b10e92c2c /meson.build
parent5ef75cb02b2b4db5506b8bf5962ac165f9314b9c (diff)
meson: fix deps and underlinkage of libGL
Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9222e6ec230..aa923cd472b 100644
--- a/meson.build
+++ b/meson.build
@@ -888,7 +888,7 @@ if with_platform_x11
dep_x11 = dependency('x11')
dep_xext = dependency('xext')
dep_xcb = dependency('xcb')
- elif with_glx == 'dri' and with_dri_platform == 'drm'
+ elif with_glx == 'dri'
dep_x11 = dependency('x11')
dep_xext = dependency('xext')
dep_xdamage = dependency('xdamage', version : '>= 1.1')
@@ -896,9 +896,11 @@ if with_platform_x11
dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
dep_xxf86vm = dependency('xxf86vm', required : false)
endif
- if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
+ if with_any_vk or with_glx == 'dri'
dep_xcb = dependency('xcb')
dep_x11_xcb = dependency('x11-xcb')
+ endif
+ if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')
dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')
if with_dri3