summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2017-11-23 14:01:57 +0000
committerJon Turney <jon.turney@dronecode.org.uk>2017-11-30 15:09:21 +0000
commit3ae998a7432a3b8db8f43cf7013ce7f36cb71bfe (patch)
treece69b56a8810beefc2bae206347fb112dab9a025 /meson.build
parentdbe36e3b1788a333309c5b919a40bceaf0df3e74 (diff)
meson: don't require dri2proto for darwin or windows
Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7a7793b9961..9222e6ec230 100644
--- a/meson.build
+++ b/meson.build
@@ -910,7 +910,9 @@ if with_platform_x11
endif
endif
if with_glx == 'dri'
- dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
+ if with_dri_platform == 'drm'
+ dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
+ endif
dep_glproto = dependency('glproto', version : '>= 1.4.14')
endif
if with_egl