summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-11-20 16:26:06 -0800
committerDylan Baker <dylan@pnwbakers.com>2017-11-22 12:47:43 -0800
commit2d1a3bf657281509b3f602f71c9d9821b72675e4 (patch)
tree2f57558b13d732c2668d113fbb2d0b750dde395c /meson.build
parent48f64e591f31b1e0114b64a470144059bdb09ac3 (diff)
meson: Fix LLVM requires for radeonsi
Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index cfe4afa550d..cba08682bc5 100644
--- a/meson.build
+++ b/meson.build
@@ -718,7 +718,7 @@ if with_gallium_freedreno
endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
-if with_amd_vk
+if with_amd_vk or with_gallium_radeonsi
llvm_modules += ['amdgpu', 'bitreader', 'ipo']
endif
@@ -726,7 +726,7 @@ _llvm = get_option('llvm')
if _llvm == 'auto'
dep_llvm = dependency(
'llvm', version : '>= 3.9.0', modules : llvm_modules,
- required : with_amd_vk,
+ required : with_amd_vk or with_gallium_radeonsi,
)
with_llvm = dep_llvm.found()
elif _llvm == 'true'