summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-31 15:12:20 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-12-04 14:36:35 -0800
commit085070a2c8c91c14e5a9f46988989faf19b0a125 (patch)
tree88435a27002cc6312ea598797fbe028f8500ee1f /meson.build
parentf7f1b30f81e842db6057591470ce3cb6d4fb2795 (diff)
meson: drop gallium-media argument
This argument is the wrong approach for handling gallium media state trackers, since it doesn't allow for an auto option. Instead we'll use tristates, which do allow for auto. This option has never been wired to anything anyway. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 0 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index ddc4a44eb6f..0f515ad10b8 100644
--- a/meson.build
+++ b/meson.build
@@ -361,23 +361,6 @@ if with_dri or with_gallium
endif
endif
-with_gallium_xvmc = false
-with_gallium_vdpau = false
-with_gallium_omx = false # this is bellagio
-with_gallium_va = false
-with_gallium_media = false
-dep_va = []
-_drivers = get_option('gallium-media')
-if _drivers != ''
- _split = _drivers.split(',')
- with_gallium_xvmc = _split.contains('xvmc')
- with_gallium_vdpau = _split.contains('vdpau')
- with_gallium_omx = _split.contains('omx')
- with_gallium_va = _split.contains('va')
- with_gallium_media = (with_gallium_xvmc or with_gallium_vdpau or
- with_gallium_omx or with_gallium_va)
-endif
-
gl_pkgconfig_c_flags = []
if with_platform_x11
if with_any_vk or (with_glx == 'dri' and with_dri_platform == 'drm')